PHP 5 / WordPress on Windows

Before going live with WordPress I have decided to try it out on my laptop. It was a time to upgrade my PHP installation as well. I downloaded and installed the most recent version of PHP 5 using ZIP archive and configured Apache accordingly. However the following message appeared when I tried to install WordPress:

Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

It turned out PHP 5 was not configured to use MySQL by default. This is what I have changed in php.ini compared to php.ini-recommended.

extension_dir = "c:/php5/ext/"
...
extension=php_mysql.dll
extension=php_mysqli.dll
...
session.save_path = "c:/windows/temp/"

Unfortunately it did not help. I was still getting the same error. It was a time to finally read the PHP installation manual.

And then the mystery was uncovered. In order for PHP to access MySQL database, file libmysql.dll from PHP distribution “needs to be available to the Windows systems PATH”. I copied the file to C:\WINDOWS\system32 folder and it worked!

You Might Also Like

Comments

Leave a Reply

You may use simple HTML to add links or lists to your comment. Also use <pre><code class="language-*">...</code></pre> to mark up code snippets. We support language-js, language-markup and language-css for comments.
(Optional)